Remove the sessiond "ready" counter mechanism
[lttng-tools.git] / include / Makefile.am
index 24cbf09d8ad21553b5cc38ce4389879035fd008b..a4fa6fb3ab08ad3ca2732228b059cc8c2aa62ecd 100644 (file)
@@ -1,68 +1,71 @@
-if LTTNG_TOOLS_BUILD_GIT_SOURCE
-GIT_DESCRIBE_CMD = (cd $(top_srcdir); git describe)
-else
-GIT_DESCRIBE_CMD = /bin/true
-endif
-
 ##
-## The version.h file must be verified and generated or updated if the
-## git commit id (called git version here) changed since the last build
-## of lttng-tools.
+## This target generates an include file that contains the git version
+## string of the current branch, it must be continuously updated when
+## we build in the git repo and shipped in dist tarballs to reflect the
+## status of the tree when it was generated. If the tree is clean and
+## the current commit is tag a starting with "v", consider this a
+## release version and set an empty git version.
 ##
-version.h:
-       ##
-       ## We first create variables for the current git version and
-       ## the locations of the version.h and version.h.tmpl files.
-       ##
-       @echo $(ECHO_N) "Generating version.h... $(ECHO_C)"
-       @(version_h_tmpl="$(top_srcdir)/include/version.h.tmpl"; \
-       if [ -f "$${version_h_tmpl}" ]; then \
-               version_h="$(top_builddir)/include/version.h"; \
-               ##
-               ## Check whether we are in a git repo.
-               ##
-               git_describe="$$($(GIT_DESCRIBE_CMD) 2>/dev/null)"; \
-               if [ $$? -eq 0 ]; then \
-                       git_version="$${git_describe}"; \
-               else \
-                       git_version=""; \
-               fi; \
-               ##
-               ## If the version.h file doesn't exist or is not up to date,
-               ## We replace it by the version.h.tmpl file.
-               ##
-               if [ ! -e "$${version_h}" ] || \
-                       [ "$${version_h_tmpl}" -nt "$${version_h}" ]; then \
-                       cp "$${version_h_tmpl}" "$${version_h}"; \
+## Here is what the inline script does:
+##
+## First, delete any stale "version.i.tmp" file.
+##
+## If "bootstrap" and ".git" exists in the top source directory and the git
+## executable is available, get the current git version string in the form:
+##
+##  "latest_tag"(-"number_of_commits_on_top")(-g"latest_commit_hash")(-dirty)
+##
+## And store it in "version.i.tmp", if the current commit is tagged, the tag
+## starts with "v" and the tree is clean, consider this a release version and
+## overwrite the git version with an empty string in "version.i.tmp".
+##
+## If we don't have a "version.i.tmp" nor a "version.i", generate an empty
+## string as a failover.
+##
+## If we don't have a "version.i" or we have both files and they are different,
+## copy "version.i.tmp" over "version.i". This way the dependent targets are
+## only rebuilt when the version string changes.
+##
+version_verbose = $(version_verbose_@AM_V@)
+version_verbose_ = $(version_verbose_@AM_DEFAULT_V@)
+version_verbose_0 = @echo "  GEN       " $@;
+
+version.i:
+       $(version_verbose)rm -f version.i.tmp; \
+       if (test -r "$(top_srcdir)/bootstrap" && test -r "$(top_srcdir)/.git") && \
+                       test -x "`which git 2>&1;true`"; then \
+               GIT_VERSION_STR="`cd "$(top_srcdir)" && git describe --tags --dirty`"; \
+               GIT_CURRENT_TAG="`cd "$(top_srcdir)" && git describe --tags --exact-match --match="v[0-9]*" HEAD 2> /dev/null`"; \
+               echo "#define GIT_VERSION \"$$GIT_VERSION_STR\"" > version.i.tmp; \
+               if ! $(GREP) -- "-dirty" version.i.tmp > /dev/null && \
+                               test "x$$GIT_CURRENT_TAG" != "x"; then \
+                       echo "#define GIT_VERSION \"\"" > version.i.tmp; \
                fi; \
-               echo $(ECHO_N) "git version: \"$${git_version}\"$(ECHO_C)"; \
-               ##
-               ## We verify that git_version isn't the same as the one
-               ## currently in the file (if there is one), as we don't
-               ## want to update the file if it is already up to date.
-               ##
-               version_match='^#define GIT_VERSION.*'; \
-               old_version=$$($(GREP) "$${version_match}" "$${version_h}"); \
-               new_version="#define GIT_VERSION        \"$${git_version}\""; \
-               if [ x"$${old_version}" != x"$${new_version}" ]; then \
-                       $(SED) -i -e "s'$${version_match}'$${new_version}'" "$${version_h}"; \
-               else \
-                       echo $(ECHO_N) " (cached)$(ECHO_C)"; \
+       fi; \
+       if test ! -f version.i.tmp; then \
+               if test ! -f version.i; then \
+                       echo '#define GIT_VERSION ""' > version.i; \
                fi; \
-               echo $(ECHO_N) "... $(ECHO_C)"; \
-       fi)
-       @echo "$(ECHO_T)ok"
+       elif test ! -f version.i || \
+                       test x"`cat version.i.tmp`" != x"`cat version.i`"; then \
+               mv version.i.tmp version.i; \
+       fi; \
+       rm -f version.i.tmp; \
+       true
 
 ##
-## version.h is defined as a .PHONY file even if it's a real file as
-## we want our routine to be ran for each build.
+## version.i is defined as a .PHONY target even if it's a real file,
+## we want the target to be re-run on every make.
 ##
-.PHONY: version.h
+.PHONY: version.i
 
-CLEANFILES = version.h
+CLEANFILES = version.i.tmp
 
-nodist_noinst_HEADERS = \
-       version.h
+##
+## Only clean "version.i" on dist-clean, we need to keep it on regular
+## clean when it's part of a dist tarball.
+##
+DISTCLEANFILES = version.i
 
 lttnginclude_HEADERS = \
        lttng/health.h \
@@ -78,7 +81,9 @@ lttnginclude_HEADERS = \
        lttng/save.h \
        lttng/load.h \
        lttng/endpoint.h \
-       version.h.tmpl
+       lttng/rotation.h \
+       lttng/location.h \
+       lttng/userspace-probe.h
 
 lttngactioninclude_HEADERS= \
        lttng/action/action.h \
@@ -87,6 +92,8 @@ lttngactioninclude_HEADERS= \
 lttngconditioninclude_HEADERS= \
        lttng/condition/condition.h \
        lttng/condition/buffer-usage.h \
+       lttng/condition/session-consumed-size.h \
+       lttng/condition/session-rotation.h \
        lttng/condition/evaluation.h
 
 lttngnotificationinclude_HEADERS= \
@@ -105,9 +112,18 @@ noinst_HEADERS = \
        lttng/action/notify-internal.h \
        lttng/condition/condition-internal.h \
        lttng/condition/buffer-usage-internal.h \
+       lttng/condition/session-consumed-size-internal.h \
        lttng/condition/evaluation-internal.h \
+       lttng/condition/session-rotation-internal.h \
        lttng/notification/notification-internal.h \
        lttng/trigger/trigger-internal.h \
        lttng/endpoint-internal.h \
        lttng/notification/channel-internal.h \
-       lttng/channel-internal.h
+       lttng/channel-internal.h \
+       lttng/event-internal.h \
+       lttng/rotate-internal.h \
+       lttng/ref-internal.h \
+       lttng/location-internal.h \
+       lttng/userspace-probe-internal.h \
+       version.h \
+       version.i
This page took 0.026038 seconds and 5 git commands to generate.