Separate session info from channel info in notification thread
[lttng-tools.git] / include / Makefile.am
index 0536dcdf00e328a1f83433df310e7a37c888c622..ab4665d5ba6f0d370dbed46fef9391a2c3e3faff 100644 (file)
@@ -21,7 +21,7 @@ version.h:
                ##
                ## Check whether we are in a git repo.
                ##
-               git_describe="$$($(GIT_DESCRIBE_CMD) 2>/dev/null)"; \
+               git_describe="`$(GIT_DESCRIBE_CMD) 2>/dev/null`"; \
                if [ $$? -eq 0 ]; then \
                        git_version="$${git_describe}"; \
                else \
@@ -77,10 +77,40 @@ lttnginclude_HEADERS = \
        lttng/snapshot.h \
        lttng/save.h \
        lttng/load.h \
+       lttng/endpoint.h \
+       lttng/rotation.h \
        version.h.tmpl
 
+lttngactioninclude_HEADERS= \
+       lttng/action/action.h \
+       lttng/action/notify.h
+
+lttngconditioninclude_HEADERS= \
+       lttng/condition/condition.h \
+       lttng/condition/buffer-usage.h \
+       lttng/condition/evaluation.h
+
+lttngnotificationinclude_HEADERS= \
+       lttng/notification/channel.h \
+       lttng/notification/notification.h
+
+lttngtriggerinclude_HEADERS= \
+       lttng/trigger/trigger.h
+
 noinst_HEADERS = \
        lttng/snapshot-internal.h \
        lttng/health-internal.h \
        lttng/save-internal.h \
-       lttng/load-internal.h
+       lttng/load-internal.h \
+       lttng/action/action-internal.h \
+       lttng/action/notify-internal.h \
+       lttng/condition/condition-internal.h \
+       lttng/condition/buffer-usage-internal.h \
+       lttng/condition/evaluation-internal.h \
+       lttng/notification/notification-internal.h \
+       lttng/trigger/trigger-internal.h \
+       lttng/endpoint-internal.h \
+       lttng/notification/channel-internal.h \
+       lttng/channel-internal.h \
+       lttng/rotate-internal.h \
+       lttng/ref-internal.h
This page took 0.024801 seconds and 5 git commands to generate.