Separate session info from channel info in notification thread
[lttng-tools.git] / include / Makefile.am
index a30002e29253a084e313719c244189518e30b74e..ab4665d5ba6f0d370dbed46fef9391a2c3e3faff 100644 (file)
@@ -14,14 +14,14 @@ version.h:
        ## We first create variables for the current git version and
        ## the locations of the version.h and version.h.tmpl files.
        ##
-       @echo -n "Generating version.h... "
+       @echo $(ECHO_N) "Generating version.h... $(ECHO_C)"
        @(version_h_tmpl="$(top_srcdir)/include/version.h.tmpl"; \
        if [ -f "$${version_h_tmpl}" ]; then \
                version_h="$(top_builddir)/include/version.h"; \
                ##
                ## Check whether we are in a git repo.
                ##
-               git_describe="$$($(GIT_DESCRIBE_CMD) 2>/dev/null)"; \
+               git_describe="`$(GIT_DESCRIBE_CMD) 2>/dev/null`"; \
                if [ $$? -eq 0 ]; then \
                        git_version="$${git_describe}"; \
                else \
@@ -35,23 +35,23 @@ version.h:
                        [ "$${version_h_tmpl}" -nt "$${version_h}" ]; then \
                        cp "$${version_h_tmpl}" "$${version_h}"; \
                fi; \
-               echo -n "git version: \"$${git_version}\""; \
+               echo $(ECHO_N) "git version: \"$${git_version}\"$(ECHO_C)"; \
                ##
                ## We verify that git_version isn't the same as the one
                ## currently in the file (if there is one), as we don't
                ## want to update the file if it is already up to date.
                ##
                version_match='^#define GIT_VERSION.*'; \
-               old_version=$$(grep "$${version_match}" "$${version_h}"); \
+               old_version=$$($(GREP) "$${version_match}" "$${version_h}"); \
                new_version="#define GIT_VERSION        \"$${git_version}\""; \
                if [ x"$${old_version}" != x"$${new_version}" ]; then \
-                       sed -i "s'$${version_match}'$${new_version}'" "$${version_h}"; \
+                       $(SED) -i -e "s'$${version_match}'$${new_version}'" "$${version_h}"; \
                else \
-                       echo -n " (cached)"; \
+                       echo $(ECHO_N) " (cached)$(ECHO_C)"; \
                fi; \
-               echo -n "... "; \
+               echo $(ECHO_N) "... $(ECHO_C)"; \
        fi)
-       @echo "ok"
+       @echo "$(ECHO_T)ok"
 
 ##
 ## version.h is defined as a .PHONY file even if it's a real file as
@@ -59,6 +59,8 @@ version.h:
 ##
 .PHONY: version.h
 
+CLEANFILES = version.h
+
 nodist_noinst_HEADERS = \
        version.h
 
@@ -75,10 +77,40 @@ lttnginclude_HEADERS = \
        lttng/snapshot.h \
        lttng/save.h \
        lttng/load.h \
+       lttng/endpoint.h \
+       lttng/rotation.h \
        version.h.tmpl
 
+lttngactioninclude_HEADERS= \
+       lttng/action/action.h \
+       lttng/action/notify.h
+
+lttngconditioninclude_HEADERS= \
+       lttng/condition/condition.h \
+       lttng/condition/buffer-usage.h \
+       lttng/condition/evaluation.h
+
+lttngnotificationinclude_HEADERS= \
+       lttng/notification/channel.h \
+       lttng/notification/notification.h
+
+lttngtriggerinclude_HEADERS= \
+       lttng/trigger/trigger.h
+
 noinst_HEADERS = \
        lttng/snapshot-internal.h \
        lttng/health-internal.h \
        lttng/save-internal.h \
-       lttng/load-internal.h
+       lttng/load-internal.h \
+       lttng/action/action-internal.h \
+       lttng/action/notify-internal.h \
+       lttng/condition/condition-internal.h \
+       lttng/condition/buffer-usage-internal.h \
+       lttng/condition/evaluation-internal.h \
+       lttng/notification/notification-internal.h \
+       lttng/trigger/trigger-internal.h \
+       lttng/endpoint-internal.h \
+       lttng/notification/channel-internal.h \
+       lttng/channel-internal.h \
+       lttng/rotate-internal.h \
+       lttng/ref-internal.h
This page took 0.024857 seconds and 5 git commands to generate.