event-rule: introduce event rule uprobe
[lttng-tools.git] / include / Makefile.am
index 79597f4f2bc81984819bbc88dd7d5852010c1c4d..b5875cd6686574b9d33efd5fc96df3005d9dc9e7 100644 (file)
@@ -1,3 +1,4 @@
+## SPDX-License-Identifier: GPL-2.0-only
 ##
 ## This target generates an include file that contains the git version
 ## string of the current branch, it must be continuously updated when
@@ -51,6 +52,9 @@ version_verbose_0 = @echo "  GEN       " $@;
 
 version.i:
        $(version_verbose)rm -f version.i.tmp; \
+       if (test ! -f version.i && test -f "$(top_srcdir)/include/version.i"); then \
+               cp "$(top_srcdir)/include/version.i" version.i; \
+       fi; \
        if (test -r "$(top_srcdir)/bootstrap" && test -r "$(top_srcdir)/.git") && \
                        test -x "`which git 2>&1;true`"; then \
                GIT_VERSION_STR="`cd "$(top_srcdir)" && git describe --tags --dirty`"; \
@@ -110,11 +114,20 @@ lttnginclude_HEADERS = \
        lttng/location.h \
        lttng/userspace-probe.h \
        lttng/session-descriptor.h \
-       lttng/destruction-handle.h
+       lttng/destruction-handle.h \
+       lttng/clear.h \
+       lttng/clear-handle.h \
+       lttng/tracker.h \
+       lttng/kernel-probe.h
 
 lttngactioninclude_HEADERS= \
        lttng/action/action.h \
-       lttng/action/notify.h
+       lttng/action/group.h \
+       lttng/action/notify.h \
+       lttng/action/rotate-session.h \
+       lttng/action/snapshot-session.h \
+       lttng/action/start-session.h \
+       lttng/action/stop-session.h
 
 lttngconditioninclude_HEADERS= \
        lttng/condition/condition.h \
@@ -130,13 +143,24 @@ lttngnotificationinclude_HEADERS= \
 lttngtriggerinclude_HEADERS= \
        lttng/trigger/trigger.h
 
+lttngeventruleinclude_HEADERS= \
+       lttng/event-rule/event-rule.h \
+       lttng/event-rule/kprobe.h \
+       lttng/event-rule/syscall.h \
+       lttng/event-rule/uprobe.h
+
 noinst_HEADERS = \
        lttng/snapshot-internal.h \
        lttng/health-internal.h \
        lttng/save-internal.h \
        lttng/load-internal.h \
        lttng/action/action-internal.h \
+       lttng/action/group-internal.h \
        lttng/action/notify-internal.h \
+       lttng/action/rotate-session-internal.h \
+       lttng/action/snapshot-session-internal.h \
+       lttng/action/start-session-internal.h \
+       lttng/action/stop-session-internal.h \
        lttng/condition/condition-internal.h \
        lttng/condition/buffer-usage-internal.h \
        lttng/condition/session-consumed-size-internal.h \
@@ -154,5 +178,10 @@ noinst_HEADERS = \
        lttng/userspace-probe-internal.h \
        lttng/session-internal.h \
        lttng/session-descriptor-internal.h \
+       lttng/kernel-probe-internal.h \
+       lttng/event-rule/event-rule-internal.h \
+       lttng/event-rule/kprobe-internal.h \
+       lttng/event-rule/syscall-internal.h \
+       lttng/event-rule/uprobe-internal.h \
        version.h \
        version.i
This page took 0.024347 seconds and 5 git commands to generate.