Fix disable event
[lttng-tools.git] / ltt-sessiond / Makefile.am
index e1b42ca09ef6699ed46f31716417d74a55a47b2a..cdcdfc60e83dad3430cfc85375d711432265aa5f 100644 (file)
@@ -6,25 +6,28 @@ AM_CFLAGS = -fno-strict-aliasing
 bin_PROGRAMS = ltt-sessiond
 
 if COMPAT_EPOLL
-COMPAT=compat-epoll.c
+COMPAT=compat/compat-epoll.c
 else
-COMPAT=compat-poll.c
+COMPAT=compat/compat-poll.c
 endif
 
 ltt_sessiond_SOURCES = utils.c utils.h \
+                       compat/poll.h $(COMPAT) \
                        trace-kernel.c trace-kernel.h \
                        trace-ust.c trace-ust.h \
-                       traceable-app.c traceable-app.h \
+                       ust-app.c ust-app.h \
                        ust-comm.c ust-comm.h \
                        ust-ctl.c ust-ctl.h \
                        kernel-ctl.c kernel-ctl.h \
                        context.c context.h \
+                       channel.c channel.h \
+                       event.c event.h \
                        futex.c futex.h \
                        shm.c shm.h \
-                       poll.h \
-                       $(COMPAT) \
                        session.c session.h \
-                       ltt-sessiond.h main.c
+                       ltt-sessiond.h main.c \
+                       ../hashtable/rculfhash.c \
+                       ../hashtable/rculfhash.h
 
 # link on liblttngctl for check if sessiond is already alive.
 ltt_sessiond_LDADD = -lrt \
This page took 0.024165 seconds and 5 git commands to generate.