Add epoll check to autoconf and Makefile
[lttng-tools.git] / ltt-sessiond / Makefile.am
index 6cffbd738e06aead5fa803415f9de58258119a50..e1b42ca09ef6699ed46f31716417d74a55a47b2a 100644 (file)
@@ -5,20 +5,29 @@ AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = ltt-sessiond
 
+if COMPAT_EPOLL
+COMPAT=compat-epoll.c
+else
+COMPAT=compat-poll.c
+endif
+
 ltt_sessiond_SOURCES = utils.c utils.h \
                        trace-kernel.c trace-kernel.h \
                        trace-ust.c trace-ust.h \
-                       session.c session.h \
                        traceable-app.c traceable-app.h \
+                       ust-comm.c ust-comm.h \
                        ust-ctl.c ust-ctl.h \
                        kernel-ctl.c kernel-ctl.h \
                        context.c context.h \
                        futex.c futex.h \
-                       ust-comm.c ust-comm.h \
+                       shm.c shm.h \
+                       poll.h \
+                       $(COMPAT) \
+                       session.c session.h \
                        ltt-sessiond.h main.c
 
 # link on liblttngctl for check if sessiond is already alive.
-ltt_sessiond_LDADD = \
+ltt_sessiond_LDADD = -lrt \
                 $(top_builddir)/liblttng-sessiond-comm/liblttng-sessiond-comm.la \
                 $(top_builddir)/libkernelctl/libkernelctl.la \
                 $(top_builddir)/libustctl/libustctl.la \
This page took 0.02428 seconds and 5 git commands to generate.