Add epoll check to autoconf and Makefile
[lttng-tools.git] / ltt-sessiond / Makefile.am
index d24a23aec8ad04afc503fa03df140eb6380b4c0a..e1b42ca09ef6699ed46f31716417d74a55a47b2a 100644 (file)
@@ -1,9 +1,34 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/liblttsessiondcomm
+AM_CPPFLAGS = -I$(top_srcdir)/include \
+                         -DINSTALL_BIN_PATH=\""$(bindir)"\"
+
 AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = ltt-sessiond
 
-ltt_sessiond_SOURCES = session.c trace.c traceable-app.c main.c
+if COMPAT_EPOLL
+COMPAT=compat-epoll.c
+else
+COMPAT=compat-poll.c
+endif
+
+ltt_sessiond_SOURCES = utils.c utils.h \
+                       trace-kernel.c trace-kernel.h \
+                       trace-ust.c trace-ust.h \
+                       traceable-app.c traceable-app.h \
+                       ust-comm.c ust-comm.h \
+                       ust-ctl.c ust-ctl.h \
+                       kernel-ctl.c kernel-ctl.h \
+                       context.c context.h \
+                       futex.c futex.h \
+                       shm.c shm.h \
+                       poll.h \
+                       $(COMPAT) \
+                       session.c session.h \
+                       ltt-sessiond.h main.c
 
-ltt_sessiond_LDADD = \
-                $(top_builddir)/liblttsessiondcomm/liblttsessiondcomm.la
+# link on liblttngctl for check if sessiond is already alive.
+ltt_sessiond_LDADD = -lrt \
+                $(top_builddir)/liblttng-sessiond-comm/liblttng-sessiond-comm.la \
+                $(top_builddir)/libkernelctl/libkernelctl.la \
+                $(top_builddir)/libustctl/libustctl.la \
+                $(top_builddir)/liblttngctl/liblttngctl.la
This page took 0.024673 seconds and 5 git commands to generate.