Move hash table to common/ directory
[lttng-tools.git] / lttng-sessiond / Makefile.am
index d3900d22d8cf4c1d49306fb8ea8ced1e51894544..00a87f4c3cefd03d4e831035beeb8cdb6e4e7b6c 100644 (file)
@@ -13,7 +13,6 @@ COMPAT=compat/compat-poll.c
 endif
 
 lttng_sessiond_SOURCES = utils.c utils.h \
-                       hashtable.c hashtable.h \
                        compat/poll.h $(COMPAT) \
                        trace-kernel.c trace-kernel.h \
                        kernel.c kernel.h \
@@ -24,10 +23,7 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        futex.c futex.h \
                        shm.c shm.h \
                        session.c session.h \
-                       lttng-ust-ctl.h lttng-ust-abi.h \
-                       ../hashtable/rculfhash.c \
-                       ../hashtable/rculfhash.h \
-                       ../hashtable/hash.c ../hashtable/hash.h
+                       lttng-ust-ctl.h lttng-ust-abi.h
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_SOURCES += trace-ust.c ust-app.c ust-consumer.c ust-consumer.h
@@ -41,7 +37,8 @@ lttng_sessiond_LDADD = -lrt -lurcu-common -lurcu \
                 $(top_builddir)/liblttng-sessiond-comm/liblttng-sessiond-comm.la \
                 $(top_builddir)/libkernelctl/libkernelctl.la \
                 $(top_builddir)/liblttngctl/liblttngctl.la \
-                $(top_builddir)/librunas/librunas.la
+                $(top_builddir)/librunas/librunas.la \
+                $(top_builddir)/common/libcommon.la
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_LDADD += -llttng-ust-ctl
This page took 0.023959 seconds and 5 git commands to generate.