Update version to 2.0-pre17
[lttng-tools.git] / lttng-sessiond / Makefile.am
index 15e28ce06c5bf469869584d6477caa5287bd8a00..8fcea947e2fcf20497a8965bfb1aea551bb27602 100644 (file)
@@ -1,5 +1,6 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include \
-                         -DINSTALL_BIN_PATH=\""$(bindir)"\"
+                         -DINSTALL_BIN_PATH=\""$(bindir)"\" \
+                         -DINSTALL_LIB_PATH=\""$(libdir)"\"
 
 AM_CFLAGS = -fno-strict-aliasing
 
@@ -12,10 +13,9 @@ COMPAT=compat/compat-poll.c
 endif
 
 lttng_sessiond_SOURCES = utils.c utils.h \
-                       hashtable.c hashtable.h \
                        compat/poll.h $(COMPAT) \
                        trace-kernel.c trace-kernel.h \
-                       kernel-ctl.c kernel-ctl.h \
+                       kernel.c kernel.h \
                        ust-ctl.h ust-app.h trace-ust.h \
                        context.c context.h \
                        channel.c channel.h \
@@ -23,9 +23,7 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        futex.c futex.h \
                        shm.c shm.h \
                        session.c session.h \
-                       ../hashtable/rculfhash.c \
-                       ../hashtable/rculfhash.h \
-                       ../hashtable/hash.c ../hashtable/hash.h
+                       lttng-ust-ctl.h lttng-ust-abi.h
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_SOURCES += trace-ust.c ust-app.c ust-consumer.c ust-consumer.h
@@ -38,8 +36,10 @@ lttng_sessiond_SOURCES += lttng-sessiond.h main.c
 lttng_sessiond_LDADD = -lrt -lurcu-common -lurcu \
                 $(top_builddir)/liblttng-sessiond-comm/liblttng-sessiond-comm.la \
                 $(top_builddir)/libkernelctl/libkernelctl.la \
-                $(top_builddir)/liblttngctl/liblttngctl.la
+                $(top_builddir)/liblttngctl/liblttngctl.la \
+                $(top_builddir)/common/libcommon.la \
+                $(top_builddir)/liblttng-ht/liblttng-ht.la
 
 if HAVE_LIBLTTNG_UST_CTL
-lttng_sessiond_LDADD += -llttng-ust-comm -llttng-ust-ctl
+lttng_sessiond_LDADD += -llttng-ust-ctl
 endif
This page took 0.025029 seconds and 5 git commands to generate.