Select which binaries/extras to build at configure time
[lttng-tools.git] / src / bin / Makefile.am
index 07b694918c3d9a28b7d8531d8a8aed3561d1ff39..73cfac7b76986076f031299fc630f498ac375c9d 100644 (file)
@@ -1,8 +1,28 @@
 ACLOCAL_AMFLAGS = -I config
 
-SUBDIRS = lttng-consumerd
+SUBDIRS =
 
-if ! BUILD_CONSUMERD_ONLY
-SUBDIRS += lttng \
-           lttng-sessiond
+# Make sure to always distribute all folders
+# since SUBDIRS is decided at configure time.
+DIST_SUBDIRS = lttng-consumerd lttng lttng-sessiond lttng-relayd \
+              lttng-crash
+
+if BUILD_BIN_LTTNG
+SUBDIRS += lttng
+endif
+
+if BUILD_BIN_LTTNG_CONSUMERD
+SUBDIRS += lttng-consumerd
+endif
+
+if BUILD_BIN_LTTNG_CRASH
+SUBDIRS += lttng-crash
+endif
+
+if BUILD_BIN_LTTNG_RELAYD
+SUBDIRS += lttng-relayd
+endif
+
+if BUILD_BIN_LTTNG_SESSIOND
+SUBDIRS += lttng-sessiond
 endif
This page took 0.024931 seconds and 5 git commands to generate.