Implement the relayd live features
[lttng-tools.git] / src / bin / lttng-relayd / Makefile.am
index 57045463a7b688e477eff8a0d2cc48af7d6b508e..4f23dbc437456733c438564955c339a1ab3a7d94 100644 (file)
@@ -6,10 +6,12 @@ AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = lttng-relayd
 
-lttng_relayd_SOURCES = main.c lttng-relayd.h utils.h utils.c \
+lttng_relayd_SOURCES = main.c lttng-relayd.h utils.h utils.c cmd.h \
+                       index.c index.h live.c live.h ctf-trace.c ctf-trace.h \
                        cmd-generic.c cmd-generic.h \
                        cmd-2-1.c cmd-2-1.h \
-                       cmd-2-2.c cmd-2-2.h
+                       cmd-2-2.c cmd-2-2.h \
+                       cmd-2-4.c cmd-2-4.h
 
 # link on liblttngctl for check if relayd is already alive.
 lttng_relayd_LDADD = -lrt -lurcu-common -lurcu \
@@ -17,4 +19,5 @@ lttng_relayd_LDADD = -lrt -lurcu-common -lurcu \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/hashtable/libhashtable.la \
                $(top_builddir)/src/common/libcommon.la \
-               $(top_builddir)/src/common/compat/libcompat.la
+               $(top_builddir)/src/common/compat/libcompat.la \
+               $(top_builddir)/src/common/index/libindex.la
This page took 0.025526 seconds and 5 git commands to generate.