Rename sessiond-timer.[hc] to timer.[hc]
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index 0fab90f335bc4bd472c8f31b2edf549424d0bb6a..2e4b95dcef0beb5334f130fe20e9134854d02e01 100644 (file)
@@ -1,8 +1,9 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src \
-                         -DINSTALL_BIN_PATH=\""$(lttnglibexecdir)"\" \
-                         -DINSTALL_LIB_PATH=\""$(libdir)"\"
+AM_CPPFLAGS +=-DINSTALL_BIN_PATH=\""$(lttnglibexecdir)"\" \
+       -DINSTALL_LIB_PATH=\""$(libdir)"\"
 
-AM_CFLAGS = -fno-strict-aliasing
+if EMBED_HELP
+AM_CPPFLAGS += -I$(top_builddir)/doc/man
+endif
 
 bin_PROGRAMS = lttng-sessiond
 
@@ -22,23 +23,36 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        fd-limit.c fd-limit.h \
                        kernel-consumer.c kernel-consumer.h \
                        consumer.h \
-                       health.c health.h health-sessiond.h \
+                       health-sessiond.h \
                        cmd.c cmd.h \
                        buffer-registry.c buffer-registry.h \
-                       testpoint.h ht-cleanup.c \
-                       snapshot.c snapshot.h
+                       testpoint.h ht-cleanup.c ht-cleanup.h \
+                       snapshot.c snapshot.h \
+                       agent.c agent.h \
+                       save.h save.c \
+                       load-session-thread.h load-session-thread.c \
+                       lttng-syscall.h lttng-syscall.c \
+                       notification-thread.h notification-thread.c \
+                       notification-thread-internal.h \
+                       notification-thread-commands.h notification-thread-commands.c \
+                       notification-thread-events.h notification-thread-events.c \
+                       sessiond-config.h sessiond-config.c \
+                       rotate.h rotate.c \
+                       rotation-thread.h rotation-thread.c \
+                       timer.c timer.h
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_SOURCES += trace-ust.c ust-registry.c ust-app.c \
                        ust-consumer.c ust-consumer.h ust-thread.c \
-                       ust-metadata.c ust-clock.h
+                       ust-metadata.c ust-clock.h agent-thread.c agent-thread.h \
+                       ust-field-utils.h ust-field-utils.c
 endif
 
 # Add main.c at the end for compile order
 lttng_sessiond_SOURCES += lttng-sessiond.h main.c
 
 # link on liblttngctl for check if sessiond is already alive.
-lttng_sessiond_LDADD = -lrt -lurcu-common -lurcu \
+lttng_sessiond_LDADD = -lurcu-common -lurcu $(KMOD_LIBS) \
                $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/kernel-ctl/libkernel-ctl.la \
@@ -46,7 +60,11 @@ lttng_sessiond_LDADD = -lrt -lurcu-common -lurcu \
                $(top_builddir)/src/common/libcommon.la \
                $(top_builddir)/src/common/compat/libcompat.la \
                $(top_builddir)/src/common/relayd/librelayd.la \
-               $(top_builddir)/src/common/testpoint/libtestpoint.la
+               $(top_builddir)/src/common/testpoint/libtestpoint.la \
+               $(top_builddir)/src/common/health/libhealth.la \
+               $(top_builddir)/src/common/config/libconfig.la \
+               $(top_builddir)/src/common/string-utils/libstring-utils.la
+
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_LDADD += -llttng-ust-ctl
This page took 0.024532 seconds and 5 git commands to generate.