Move health into its own common/ static library
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index 44948fc1428ed0fa78f2caefb6ed7c43c3e116db..3d96907deac377f4e70ed64c5037ec6e9883f3b0 100644 (file)
@@ -1,4 +1,5 @@
-AM_CPPFLAGS = -DINSTALL_BIN_PATH=\""$(bindir)"\" \
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src \
+                         -DINSTALL_BIN_PATH=\""$(lttnglibexecdir)"\" \
                          -DINSTALL_LIB_PATH=\""$(libdir)"\"
 
 AM_CFLAGS = -fno-strict-aliasing
@@ -8,18 +9,29 @@ bin_PROGRAMS = lttng-sessiond
 lttng_sessiond_SOURCES = utils.c utils.h \
                        trace-kernel.c trace-kernel.h \
                        kernel.c kernel.h \
-                       ust-ctl.h ust-app.h trace-ust.h \
+                       ust-ctl.h ust-app.h trace-ust.h ust-thread.h \
+                       ust-registry.h \
                        context.c context.h \
                        channel.c channel.h \
                        event.c event.h \
-                       futex.c futex.h \
                        shm.c shm.h \
+                       consumer.c consumer.h \
                        session.c session.h \
                        modprobe.c modprobe.h kern-modules.h \
-                       lttng-ust-ctl.h lttng-ust-abi.h
+                       lttng-ust-ctl.h lttng-ust-abi.h lttng-ust-error.h \
+                       fd-limit.c fd-limit.h \
+                       kernel-consumer.c kernel-consumer.h \
+                       consumer.h \
+                       health-sessiond.h \
+                       cmd.c cmd.h \
+                       buffer-registry.c buffer-registry.h \
+                       testpoint.h ht-cleanup.c \
+                       snapshot.c snapshot.h
 
 if HAVE_LIBLTTNG_UST_CTL
-lttng_sessiond_SOURCES += trace-ust.c ust-app.c ust-consumer.c ust-consumer.h
+lttng_sessiond_SOURCES += trace-ust.c ust-registry.c ust-app.c \
+                       ust-consumer.c ust-consumer.h ust-thread.c \
+                       ust-metadata.c ust-clock.h
 endif
 
 # Add main.c at the end for compile order
@@ -32,7 +44,10 @@ lttng_sessiond_LDADD = -lrt -lurcu-common -lurcu \
                $(top_builddir)/src/common/kernel-ctl/libkernel-ctl.la \
                $(top_builddir)/src/common/hashtable/libhashtable.la \
                $(top_builddir)/src/common/libcommon.la \
-               $(top_builddir)/src/common/compat/libcompat.la
+               $(top_builddir)/src/common/compat/libcompat.la \
+               $(top_builddir)/src/common/relayd/librelayd.la \
+               $(top_builddir)/src/common/testpoint/libtestpoint.la \
+               $(top_builddir)/src/common/health/libhealth.la
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_LDADD += -llttng-ust-ctl
This page took 0.025058 seconds and 5 git commands to generate.