Load session daemon options from configuration file
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index 3d96907deac377f4e70ed64c5037ec6e9883f3b0..53433d0333015a18431a152765d388d66d23965b 100644 (file)
@@ -26,12 +26,13 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        cmd.c cmd.h \
                        buffer-registry.c buffer-registry.h \
                        testpoint.h ht-cleanup.c \
-                       snapshot.c snapshot.h
+                       snapshot.c snapshot.h \
+                       jul.c jul.h
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_SOURCES += trace-ust.c ust-registry.c ust-app.c \
                        ust-consumer.c ust-consumer.h ust-thread.c \
-                       ust-metadata.c ust-clock.h
+                       ust-metadata.c ust-clock.h jul-thread.c jul-thread.h
 endif
 
 # Add main.c at the end for compile order
@@ -47,7 +48,9 @@ lttng_sessiond_LDADD = -lrt -lurcu-common -lurcu \
                $(top_builddir)/src/common/compat/libcompat.la \
                $(top_builddir)/src/common/relayd/librelayd.la \
                $(top_builddir)/src/common/testpoint/libtestpoint.la \
-               $(top_builddir)/src/common/health/libhealth.la
+               $(top_builddir)/src/common/health/libhealth.la \
+               $(top_builddir)/src/common/config/libconfig.la
+
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_LDADD += -llttng-ust-ctl
This page took 0.024547 seconds and 5 git commands to generate.