Load session daemon options from configuration file
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index ae8b6eb1e476ef8310a75ee473fa7cbba3afd502..53433d0333015a18431a152765d388d66d23965b 100644 (file)
@@ -22,15 +22,17 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        fd-limit.c fd-limit.h \
                        kernel-consumer.c kernel-consumer.h \
                        consumer.h \
-                       health.c health.h \
+                       health-sessiond.h \
                        cmd.c cmd.h \
                        buffer-registry.c buffer-registry.h \
-                       testpoint.h ht-cleanup.c
+                       testpoint.h ht-cleanup.c \
+                       snapshot.c snapshot.h \
+                       jul.c jul.h
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_SOURCES += trace-ust.c ust-registry.c ust-app.c \
                        ust-consumer.c ust-consumer.h ust-thread.c \
-                       ust-metadata.c ust-clock.h
+                       ust-metadata.c ust-clock.h jul-thread.c jul-thread.h
 endif
 
 # Add main.c at the end for compile order
@@ -45,7 +47,10 @@ lttng_sessiond_LDADD = -lrt -lurcu-common -lurcu \
                $(top_builddir)/src/common/libcommon.la \
                $(top_builddir)/src/common/compat/libcompat.la \
                $(top_builddir)/src/common/relayd/librelayd.la \
-               $(top_builddir)/src/common/testpoint/libtestpoint.la
+               $(top_builddir)/src/common/testpoint/libtestpoint.la \
+               $(top_builddir)/src/common/health/libhealth.la \
+               $(top_builddir)/src/common/config/libconfig.la
+
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_LDADD += -llttng-ust-ctl
This page took 0.024498 seconds and 5 git commands to generate.