doc/man: use specific revision date for each manual page
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index 529887b8a75ae12a6e2f4542550cca5d3aa680f2..9800c4b2ccc065beb851b09d6a9c60d2658108c9 100644 (file)
@@ -10,7 +10,7 @@ bin_PROGRAMS = lttng-sessiond
 lttng_sessiond_SOURCES = utils.c utils.h \
                        trace-kernel.c trace-kernel.h \
                        kernel.c kernel.h \
-                       ust-ctl.h ust-app.h trace-ust.h ust-thread.h \
+                       ust-ctl.h ust-app.h trace-ust.h notify-apps.h \
                        ust-registry.h \
                        context.c context.h \
                        channel.c channel.h \
@@ -30,23 +30,39 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        snapshot.c snapshot.h \
                        agent.c agent.h \
                        save.h save.c \
-                       load-session-thread.h load-session-thread.c \
-                       syscall.h syscall.c \
+                       lttng-syscall.h lttng-syscall.c \
                        notification-thread.h notification-thread.c \
+                       notification-thread-internal.h \
                        notification-thread-commands.h notification-thread-commands.c \
-                       notification-thread-events.h notification-thread-events.c
+                       notification-thread-events.h notification-thread-events.c \
+                       sessiond-config.h sessiond-config.c \
+                       rotate.h rotate.c \
+                       rotation-thread.h rotation-thread.c \
+                       timer.c timer.h \
+                       globals.c \
+                       thread-utils.c \
+                       process-utils.c \
+                       thread.c thread.h \
+                       health.c \
+                       client.c client.h \
+                       dispatch.c dispatch.h \
+                       register.c register.h \
+                       manage-apps.c manage-apps.h \
+                       manage-kernel.c manage-kernel.h \
+                       manage-consumer.c manage-consumer.h
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_SOURCES += trace-ust.c ust-registry.c ust-app.c \
-                       ust-consumer.c ust-consumer.h ust-thread.c \
-                       ust-metadata.c ust-clock.h agent-thread.c agent-thread.h
+                       ust-consumer.c ust-consumer.h notify-apps.c \
+                       ust-metadata.c ust-clock.h agent-thread.c agent-thread.h \
+                       ust-field-utils.h ust-field-utils.c
 endif
 
 # Add main.c at the end for compile order
 lttng_sessiond_SOURCES += lttng-sessiond.h main.c
 
 # link on liblttngctl for check if sessiond is already alive.
-lttng_sessiond_LDADD = -lurcu-common -lurcu \
+lttng_sessiond_LDADD = -lurcu-common -lurcu $(KMOD_LIBS) \
                $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/kernel-ctl/libkernel-ctl.la \
This page took 0.02607 seconds and 5 git commands to generate.