Fix: lttng view, error message and exit code
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index c431ade868b1717a4acbbd7963976fd3fd94d98e..ccdbe3afc49485af896cad9c5e61918a997ce4d3 100644 (file)
@@ -1,4 +1,4 @@
-AM_CPPFLAGS = -DINSTALL_BIN_PATH=\""$(bindir)"\" \
+AM_CPPFLAGS = -DINSTALL_BIN_PATH=\""$(lttnglibexecdir)"\" \
                          -DINSTALL_LIB_PATH=\""$(libdir)"\"
 
 AM_CFLAGS = -fno-strict-aliasing
@@ -15,6 +15,7 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        futex.c futex.h \
                        shm.c shm.h \
                        session.c session.h \
+                       modprobe.c modprobe.h kern-modules.h \
                        lttng-ust-ctl.h lttng-ust-abi.h
 
 if HAVE_LIBLTTNG_UST_CTL
@@ -31,7 +32,7 @@ lttng_sessiond_LDADD = -lrt -lurcu-common -lurcu \
                $(top_builddir)/src/common/kernel-ctl/libkernel-ctl.la \
                $(top_builddir)/src/common/hashtable/libhashtable.la \
                $(top_builddir)/src/common/libcommon.la \
-               $(top_builddir)/src/common/libcompat.la
+               $(top_builddir)/src/common/compat/libcompat.la
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_LDADD += -llttng-ust-ctl
This page took 0.025154 seconds and 5 git commands to generate.