Revert "sessiond: trigger: run trigger actions through an action executor"
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index 755c2aa0ff61153cb0151f7c45a0d70fc1933b26..ee53655be18f8390934c01269c537a9a339d0117 100644 (file)
@@ -1,19 +1,20 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src \
-                         -DINSTALL_BIN_PATH=\""$(lttnglibexecdir)"\" \
-                         -DINSTALL_LIB_PATH=\""$(libdir)"\"
+# SPDX-License-Identifier: GPL-2.0-only
+
+AM_CPPFLAGS +=-DINSTALL_BIN_PATH=\""$(lttnglibexecdir)"\" \
+       -DINSTALL_LIB_PATH=\""$(libdir)"\"
 
 if EMBED_HELP
 AM_CPPFLAGS += -I$(top_builddir)/doc/man
 endif
 
-AM_CFLAGS = -fno-strict-aliasing
-
 bin_PROGRAMS = lttng-sessiond
 
 lttng_sessiond_SOURCES = utils.c utils.h \
                        trace-kernel.c trace-kernel.h \
                        kernel.c kernel.h \
-                       ust-ctl.h ust-app.h trace-ust.h ust-thread.h \
+                       ust-app.h trace-ust.h notify-apps.h \
+                       lttng-ust-ctl.h lttng-ust-abi.h lttng-ust-error.h \
+                       ust-ctl-internal.h ust-abi-internal.h ust-error-internal.h \
                        ust-registry.h \
                        context.c context.h \
                        channel.c channel.h \
@@ -22,7 +23,6 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        consumer.c consumer.h \
                        session.c session.h \
                        modprobe.c modprobe.h kern-modules.h \
-                       lttng-ust-ctl.h lttng-ust-abi.h lttng-ust-error.h \
                        fd-limit.c fd-limit.h \
                        kernel-consumer.c kernel-consumer.h \
                        consumer.h \
@@ -33,23 +33,41 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        snapshot.c snapshot.h \
                        agent.c agent.h \
                        save.h save.c \
-                       load-session-thread.h load-session-thread.c \
-                       syscall.h syscall.c \
+                       lttng-syscall.h lttng-syscall.c \
                        notification-thread.h notification-thread.c \
+                       notification-thread-internal.h \
                        notification-thread-commands.h notification-thread-commands.c \
-                       notification-thread-events.h notification-thread-events.c
+                       notification-thread-events.h notification-thread-events.c \
+                       sessiond-config.h sessiond-config.c \
+                       rotate.h rotate.c \
+                       rotation-thread.h rotation-thread.c \
+                       timer.c timer.h \
+                       globals.c \
+                       thread-utils.c \
+                       process-utils.c \
+                       thread.c thread.h \
+                       health.c \
+                       client.c client.h \
+                       dispatch.c dispatch.h \
+                       register.c register.h \
+                       manage-apps.c manage-apps.h \
+                       manage-kernel.c manage-kernel.h \
+                       manage-consumer.c manage-consumer.h \
+                       clear.c clear.h \
+                       tracker.c tracker.h
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_SOURCES += trace-ust.c ust-registry.c ust-app.c \
-                       ust-consumer.c ust-consumer.h ust-thread.c \
-                       ust-metadata.c ust-clock.h agent-thread.c agent-thread.h
+                       ust-consumer.c ust-consumer.h notify-apps.c \
+                       ust-metadata.c ust-clock.h agent-thread.c agent-thread.h \
+                       ust-field-utils.h ust-field-utils.c
 endif
 
 # Add main.c at the end for compile order
 lttng_sessiond_SOURCES += lttng-sessiond.h main.c
 
 # link on liblttngctl for check if sessiond is already alive.
-lttng_sessiond_LDADD = -lurcu-common -lurcu \
+lttng_sessiond_LDADD = -lurcu-common -lurcu $(KMOD_LIBS) \
                $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/kernel-ctl/libkernel-ctl.la \
@@ -59,9 +77,10 @@ lttng_sessiond_LDADD = -lurcu-common -lurcu \
                $(top_builddir)/src/common/relayd/librelayd.la \
                $(top_builddir)/src/common/testpoint/libtestpoint.la \
                $(top_builddir)/src/common/health/libhealth.la \
-               $(top_builddir)/src/common/config/libconfig.la
+               $(top_builddir)/src/common/config/libconfig.la \
+               $(top_builddir)/src/common/string-utils/libstring-utils.la
 
 
 if HAVE_LIBLTTNG_UST_CTL
-lttng_sessiond_LDADD += -llttng-ust-ctl
+lttng_sessiond_LDADD += $(UST_CTL_LIBS)
 endif
This page took 0.025238 seconds and 5 git commands to generate.