Add --enable-embedded-help option to embed --help messages in binaries
[lttng-tools.git] / src / bin / lttng / Makefile.am
index 28673a910360627166943d1da20e2264999dcb7f..23fff77a7f9d144900df5df2e8b0e4071dae7dde 100644 (file)
@@ -1,13 +1,31 @@
-AM_CPPFLAGS = -DINSTALL_BIN_PATH=\""$(bindir)"\"
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src \
+                         -DINSTALL_BIN_PATH=\""$(bindir)"\"
+
+if EMBED_HELP
+AM_CPPFLAGS += -I$(top_builddir)/doc/man
+endif
+
+AUTOMAKE_OPTIONS = subdir-objects
 
 bin_PROGRAMS = lttng
 
-lttng_SOURCES = cmd.h conf.c conf.h commands/start.c \
+lttng_SOURCES = command.h conf.c conf.h commands/start.c \
                                commands/list.c commands/create.c commands/destroy.c \
                                commands/stop.c commands/enable_events.c \
                                commands/disable_events.c commands/enable_channels.c \
                                commands/disable_channels.c commands/add_context.c \
                                commands/set_session.c commands/version.c \
-                               commands/calibrate.c utils.c utils.h lttng.c
+                               commands/view.c \
+                               commands/snapshot.c \
+                               commands/save.c \
+                               commands/load.c \
+                               commands/track-untrack.c \
+                               commands/status.c \
+                               commands/metadata.c \
+                               commands/regenerate.c \
+                               commands/help.c \
+                               utils.c utils.h lttng.c
 
-lttng_LDADD = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
+lttng_LDADD = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
+                       $(top_builddir)/src/common/libcommon.la \
+                       $(top_builddir)/src/common/config/libconfig.la
This page took 0.029652 seconds and 5 git commands to generate.