Add --enable-embedded-help option to embed --help messages in binaries
[lttng-tools.git] / src / bin / lttng / Makefile.am
index acd973b255b3898ac2d15025cf6d03eef446f4f0..23fff77a7f9d144900df5df2e8b0e4071dae7dde 100644 (file)
@@ -1,6 +1,10 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src \
                          -DINSTALL_BIN_PATH=\""$(bindir)"\"
 
+if EMBED_HELP
+AM_CPPFLAGS += -I$(top_builddir)/doc/man
+endif
+
 AUTOMAKE_OPTIONS = subdir-objects
 
 bin_PROGRAMS = lttng
@@ -11,7 +15,7 @@ lttng_SOURCES = command.h conf.c conf.h commands/start.c \
                                commands/disable_events.c commands/enable_channels.c \
                                commands/disable_channels.c commands/add_context.c \
                                commands/set_session.c commands/version.c \
-                               commands/calibrate.c commands/view.c \
+                               commands/view.c \
                                commands/snapshot.c \
                                commands/save.c \
                                commands/load.c \
This page took 0.023819 seconds and 5 git commands to generate.