Add --enable-embedded-help option to embed --help messages in binaries
[lttng-tools.git] / src / bin / lttng / Makefile.am
index b911f334c7bc39f1012711256884bd8d59101fc9..23fff77a7f9d144900df5df2e8b0e4071dae7dde 100644 (file)
@@ -1,6 +1,10 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src \
                          -DINSTALL_BIN_PATH=\""$(bindir)"\"
 
+if EMBED_HELP
+AM_CPPFLAGS += -I$(top_builddir)/doc/man
+endif
+
 AUTOMAKE_OPTIONS = subdir-objects
 
 bin_PROGRAMS = lttng
@@ -11,13 +15,14 @@ lttng_SOURCES = command.h conf.c conf.h commands/start.c \
                                commands/disable_events.c commands/enable_channels.c \
                                commands/disable_channels.c commands/add_context.c \
                                commands/set_session.c commands/version.c \
-                               commands/calibrate.c commands/view.c \
+                               commands/view.c \
                                commands/snapshot.c \
                                commands/save.c \
                                commands/load.c \
                                commands/track-untrack.c \
                                commands/status.c \
                                commands/metadata.c \
+                               commands/regenerate.c \
                                commands/help.c \
                                utils.c utils.h lttng.c
 
This page took 0.026191 seconds and 5 git commands to generate.