SoW-2020-0003: Trace Hit Counters
[lttng-tools.git] / src / bin / lttng / Makefile.am
index c75601f21ad3b1602606635e52e9d3c09103b98f..6c262622f10be35ef1412a7177a6fdc6f2c1157a 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CPPFLAGS += -DINSTALL_BIN_PATH=\""$(bindir)"\"
 
 if EMBED_HELP
@@ -12,9 +14,13 @@ lttng_SOURCES = command.h conf.c conf.h commands/start.c \
                                commands/list.c commands/create.c commands/destroy.c \
                                commands/stop.c commands/enable_events.c \
                                commands/disable_events.c commands/enable_channels.c \
+                               commands/add_map.c \
+                               commands/enable_map.c \
+                               commands/disable_map.c \
                                commands/disable_channels.c commands/add_context.c \
                                commands/set_session.c commands/version.c \
                                commands/view.c \
+                               commands/view_map.c \
                                commands/snapshot.c \
                                commands/save.c \
                                commands/load.c \
@@ -27,7 +33,12 @@ lttng_SOURCES = command.h conf.c conf.h commands/start.c \
                                commands/enable_rotation.c \
                                commands/disable_rotation.c \
                                commands/clear.c \
-                               utils.c utils.h lttng.c
+                               loglevel.c loglevel.h \
+                               commands/add_trigger.c \
+                               commands/list_triggers.c \
+                               commands/remove_trigger.c \
+                               utils.c utils.h lttng.c \
+                               uprobe.c uprobe.h
 
 lttng_CFLAGS = $(AM_CFLAGS) $(POPT_CFLAGS)
 
@@ -35,4 +46,7 @@ lttng_LDADD = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                        $(top_builddir)/src/common/libcommon.la \
                        $(top_builddir)/src/common/config/libconfig.la \
                        $(top_builddir)/src/common/string-utils/libstring-utils.la \
-                       $(POPT_LIBS)
+                       $(top_builddir)/src/common/filter/libfilter.la \
+                       $(top_builddir)/src/common/argpar/libargpar.la \
+                       $(POPT_LIBS) \
+                       -lm
This page took 0.027136 seconds and 5 git commands to generate.