lttng: Implement lttng clear session command
[lttng-tools.git] / src / bin / lttng / Makefile.am
index c60c0ee6d080661be0aec2bedc225b3620734b77..c75601f21ad3b1602606635e52e9d3c09103b98f 100644 (file)
@@ -1,5 +1,4 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src \
-                         -DINSTALL_BIN_PATH=\""$(bindir)"\"
+AM_CPPFLAGS += -DINSTALL_BIN_PATH=\""$(bindir)"\"
 
 if EMBED_HELP
 AM_CPPFLAGS += -I$(top_builddir)/doc/man
@@ -24,9 +23,16 @@ lttng_SOURCES = command.h conf.c conf.h commands/start.c \
                                commands/metadata.c \
                                commands/regenerate.c \
                                commands/help.c \
+                               commands/rotate.c \
+                               commands/enable_rotation.c \
+                               commands/disable_rotation.c \
+                               commands/clear.c \
                                utils.c utils.h lttng.c
 
+lttng_CFLAGS = $(AM_CFLAGS) $(POPT_CFLAGS)
+
 lttng_LDADD = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                        $(top_builddir)/src/common/libcommon.la \
                        $(top_builddir)/src/common/config/libconfig.la \
-                       $(top_builddir)/src/common/string-utils/libstring-utils.la
+                       $(top_builddir)/src/common/string-utils/libstring-utils.la \
+                       $(POPT_LIBS)
This page took 0.024645 seconds and 5 git commands to generate.