Rename lttng_event_rule_kernel_probe to lttng_event_rule_kernel_kprobe
[lttng-tools.git] / src / common / Makefile.am
index f564d383522475239214146a03655bcf403b41a2..12a6ba807678484eb9458b60a5752aaef06618b8 100644 (file)
@@ -35,18 +35,19 @@ EXTRA_DIST = mi-lttng-4.0.xsd
 
 libcommon_la_SOURCES = \
        actions/action.c \
-       actions/group.c \
+       actions/list.c \
        actions/notify.c \
+       actions/path.c \
        actions/rotate-session.c \
        actions/snapshot-session.c \
        actions/start-session.c \
        actions/stop-session.c \
-       actions/firing-policy.c \
+       actions/rate-policy.c \
        buffer-view.h buffer-view.c \
        common.h \
        conditions/buffer-usage.c \
        conditions/condition.c \
-       conditions/on-event.c \
+       conditions/event-rule-matches.c \
        conditions/session-consumed-size.c \
        conditions/session-rotation.c \
        context.c context.h \
@@ -58,14 +59,15 @@ libcommon_la_SOURCES = \
        dynamic-buffer.c dynamic-buffer.h \
        endpoint.c \
        error.c error.h \
+       error-query.c \
        evaluation.c \
        event.c \
        event-expr-to-bytecode.c event-expr-to-bytecode.h \
        event-field-value.c \
        event-rule/event-rule.c \
-       event-rule/kernel-probe.c \
-       event-rule/syscall.c \
-       event-rule/userspace-probe.c \
+       event-rule/kernel-kprobe.c \
+       event-rule/kernel-syscall.c \
+       event-rule/kernel-uprobe.c \
        event-rule/tracepoint.c \
        filter.c filter.h \
        fd-handle.c fd-handle.h \
@@ -179,6 +181,11 @@ noinst_HEADERS = \
        uri.h \
        utils.h
 
+noinst_PROGRAMS = filter-grammar-test
+filter_grammar_test_SOURCES = filter-grammar-test.c
+filter_grammar_test_LDADD = \
+       libcommon.la
+
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                for script in $(EXTRA_DIST); do \
This page took 0.025422 seconds and 5 git commands to generate.