Move unix.h wrapper from sessiond-comm to common
[lttng-tools.git] / src / common / Makefile.am
index 148130177f177d2be79fd0e99c638d64b3da6b54..193057c9b450b62ee130a8df7063e088462b9e8e 100644 (file)
@@ -1,4 +1,5 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src \
+       -DMANPATH=\""$(mandir)"\"
 
 AUTOMAKE_OPTIONS = subdir-objects
 
@@ -65,14 +66,15 @@ noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
 
 # Common library
 noinst_LTLIBRARIES = libcommon.la
-EXTRA_DIST = mi_lttng.xsd
+EXTRA_DIST = mi-lttng-3.0.xsd
 
 libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
                        common.h futex.c futex.h uri.c uri.h defaults.c \
                        pipe.c pipe.h readwrite.c readwrite.h \
                        mi-lttng.h mi-lttng.c \
                        daemonize.c daemonize.h \
-                       sessiond-comm/unix.c sessiond-comm/unix.h
+                       unix.c unix.h \
+                       filter.c filter.h context.c context.h
 
 libcommon_la_LIBADD = \
                -luuid \
This page took 0.024468 seconds and 5 git commands to generate.