Backport:Fix: Don't override user variables within the build system
[lttng-tools.git] / src / common / Makefile.am
index 193057c9b450b62ee130a8df7063e088462b9e8e..29a35e6adfb422451b20d0ad76459896293b0f87 100644 (file)
@@ -1,6 +1,3 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src \
-       -DMANPATH=\""$(mandir)"\"
-
 AUTOMAKE_OPTIONS = subdir-objects
 
 SUBDIRS =
@@ -58,11 +55,9 @@ if BUILD_LIB_CONSUMER
 SUBDIRS += consumer
 endif
 
-AM_CFLAGS = -fno-strict-aliasing
-
 noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
                                 uri.h utils.h lttng-kernel-old.h \
-                                align.h bitfield.h bug.h
+                                align.h bitfield.h bug.h time.h
 
 # Common library
 noinst_LTLIBRARIES = libcommon.la
@@ -73,13 +68,19 @@ libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
                        pipe.c pipe.h readwrite.c readwrite.h \
                        mi-lttng.h mi-lttng.c \
                        daemonize.c daemonize.h \
+                       dynamic-buffer.h dynamic-buffer.c \
+                       buffer-view.h buffer-view.c \
                        unix.c unix.h \
                        filter.c filter.h context.c context.h
 
 libcommon_la_LIBADD = \
-               -luuid \
-               -lrt \
                $(top_builddir)/src/common/config/libconfig.la
+if LTTNG_BUILD_WITH_LIBUUID
+libcommon_la_LIBADD += -luuid
+endif
+if LTTNG_BUILD_WITH_LIBC_UUID
+libcommon_la_LIBADD += -lc
+endif
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.024521 seconds and 5 git commands to generate.