actions: introduce action group
[lttng-tools.git] / src / common / Makefile.am
index 1c9c8e4f04ecfc3d677182cfe5674e0ed4308dc6..32b28c82f57e4fc6e2c4d41772f39918363edc73 100644 (file)
@@ -27,7 +27,13 @@ noinst_LTLIBRARIES = libcommon.la
 EXTRA_DIST = mi-lttng-4.0.xsd
 
 libcommon_la_SOURCES = \
-       action.c \
+       actions/action.c \
+       actions/group.c \
+       actions/notify.c \
+       actions/rotate-session.c \
+       actions/snapshot-session.c \
+       actions/start-session.c \
+       actions/stop-session.c \
        buffer-usage.c \
        buffer-view.h buffer-view.c \
        common.h \
@@ -43,11 +49,11 @@ libcommon_la_SOURCES = \
        evaluation.c \
        event.c \
        filter.c filter.h \
+       fs-handle.c fs-handle.h fs-handle-internal.h \
        futex.c futex.h \
        location.c \
        mi-lttng.c mi-lttng.h \
        notification.c \
-       notify.c \
        optional.h \
        pipe.c pipe.h \
        readwrite.c readwrite.h \
@@ -55,6 +61,8 @@ libcommon_la_SOURCES = \
        session-consumed-size.c \
        session-descriptor.c \
        session-rotation.c \
+       snapshot.c snapshot.h \
+       spawn-viewer.c spawn-viewer.h \
        time.c \
        trace-chunk.c trace-chunk.h \
        trace-chunk-registry.h \
@@ -65,8 +73,7 @@ libcommon_la_SOURCES = \
        utils.c utils.h \
        uuid.c uuid.h \
        tracker.c tracker.h \
-       waiter.c waiter.h \
-       fs-handle.h fs-handle-internal.h fs-handle.c
+       waiter.c waiter.h
 
 if HAVE_ELF_H
 libcommon_la_SOURCES += \
This page took 0.02367 seconds and 5 git commands to generate.