actions: introduce action group
[lttng-tools.git] / src / common / Makefile.am
index 95935b76e6283b2ae9a9cdf1195c60f757848a67..32b28c82f57e4fc6e2c4d41772f39918363edc73 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AUTOMAKE_OPTIONS = subdir-objects
 
 SUBDIRS = string-utils
@@ -25,7 +27,13 @@ noinst_LTLIBRARIES = libcommon.la
 EXTRA_DIST = mi-lttng-4.0.xsd
 
 libcommon_la_SOURCES = \
-       action.c \
+       actions/action.c \
+       actions/group.c \
+       actions/notify.c \
+       actions/rotate-session.c \
+       actions/snapshot-session.c \
+       actions/start-session.c \
+       actions/stop-session.c \
        buffer-usage.c \
        buffer-view.h buffer-view.c \
        common.h \
@@ -41,11 +49,11 @@ libcommon_la_SOURCES = \
        evaluation.c \
        event.c \
        filter.c filter.h \
+       fs-handle.c fs-handle.h fs-handle-internal.h \
        futex.c futex.h \
        location.c \
        mi-lttng.c mi-lttng.h \
        notification.c \
-       notify.c \
        optional.h \
        pipe.c pipe.h \
        readwrite.c readwrite.h \
@@ -53,6 +61,8 @@ libcommon_la_SOURCES = \
        session-consumed-size.c \
        session-descriptor.c \
        session-rotation.c \
+       snapshot.c snapshot.h \
+       spawn-viewer.c spawn-viewer.h \
        time.c \
        trace-chunk.c trace-chunk.h \
        trace-chunk-registry.h \
@@ -62,6 +72,7 @@ libcommon_la_SOURCES = \
        userspace-probe.c \
        utils.c utils.h \
        uuid.c uuid.h \
+       tracker.c tracker.h \
        waiter.c waiter.h
 
 if HAVE_ELF_H
@@ -72,7 +83,8 @@ endif
 libcommon_la_LIBADD = \
        $(top_builddir)/src/common/config/libconfig.la \
        $(top_builddir)/src/common/compat/libcompat.la \
-       $(top_builddir)/src/common/hashtable/libhashtable.la
+       $(top_builddir)/src/common/hashtable/libhashtable.la \
+       $(top_builddir)/src/common/fd-tracker/libfd-tracker.la
 
 if BUILD_LIB_COMPAT
 SUBDIRS += compat
This page took 0.024947 seconds and 5 git commands to generate.