Port: Add OSX libuuid compat
[lttng-tools.git] / src / common / Makefile.am
index 8633730a92b102baee5ee59f8b5b226e241750d7..37c451a45e1f5734aedba1436a5f66c8297f3d51 100644 (file)
@@ -76,9 +76,14 @@ libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
                        filter.c filter.h context.c context.h
 
 libcommon_la_LIBADD = \
-               -luuid \
                -lrt \
                $(top_builddir)/src/common/config/libconfig.la
+if LTTNG_BUILD_WITH_LIBUUID
+libcommon_la_LIBADD += -luuid
+endif
+if LTTNG_BUILD_WITH_LIBC_UUID
+libcommon_la_LIBADD += -lc
+endif
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.024367 seconds and 5 git commands to generate.