Add mkdirat utils and runas wrappers
[lttng-tools.git] / src / common / Makefile.am
index 171748f433aacc32cc3f79254e1cb1ea4e1957ec..3e816b26a27e5d977d4be0380376e4083a0c7bc8 100644 (file)
@@ -17,7 +17,7 @@ libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.h runas.c \
                        pipe.c pipe.h readwrite.c readwrite.h \
                        mi-lttng.h mi-lttng.c \
                        daemonize.c daemonize.h \
-                       unix.h \
+                       unix.c unix.h \
                        filter.c filter.h context.c context.h \
                        action.c notify.c condition.c buffer-usage.c \
                        session-consumed-size.c \
@@ -27,18 +27,18 @@ libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.h runas.c \
                        buffer-view.h buffer-view.c \
                        location.c \
                        waiter.h waiter.c \
-                       userspace-probe.c
+                       userspace-probe.c event.c time.c \
+                       session-descriptor.c credentials.h
+
+if HAVE_ELF_H
+libcommon_la_SOURCES += lttng-elf.h lttng-elf.c
+endif
 
 libcommon_la_LIBADD = \
                $(top_builddir)/src/common/config/libconfig.la \
+               $(top_builddir)/src/common/compat/libcompat.la \
                $(UUID_LIBS)
 
-if BUILD_LIB_UNIX
-libcommon_la_SOURCES += unix.c
-else
-libcommon_la_SOURCES += unix-stub.c
-endif
-
 if BUILD_LIB_COMPAT
 SUBDIRS += compat
 endif
This page took 0.025487 seconds and 5 git commands to generate.