Add mkdirat utils and runas wrappers
[lttng-tools.git] / src / common / Makefile.am
index d6a7da1d8b790fefbbfc95d60ab16b2e5fc94b82..3e816b26a27e5d977d4be0380376e4083a0c7bc8 100644 (file)
@@ -12,12 +12,12 @@ DIST_SUBDIRS = compat health hashtable kernel-ctl sessiond-comm relayd \
 noinst_LTLIBRARIES = libcommon.la
 EXTRA_DIST = mi-lttng-3.0.xsd
 
-libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.h \
+libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.h runas.c \
                        common.h futex.c futex.h uri.c uri.h defaults.c \
                        pipe.c pipe.h readwrite.c readwrite.h \
                        mi-lttng.h mi-lttng.c \
                        daemonize.c daemonize.h \
-                       unix.h \
+                       unix.c unix.h \
                        filter.c filter.h context.c context.h \
                        action.c notify.c condition.c buffer-usage.c \
                        session-consumed-size.c \
@@ -27,24 +27,18 @@ libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.h \
                        buffer-view.h buffer-view.c \
                        location.c \
                        waiter.h waiter.c \
-                       userspace-probe.c
+                       userspace-probe.c event.c time.c \
+                       session-descriptor.c credentials.h
+
+if HAVE_ELF_H
+libcommon_la_SOURCES += lttng-elf.h lttng-elf.c
+endif
 
 libcommon_la_LIBADD = \
                $(top_builddir)/src/common/config/libconfig.la \
+               $(top_builddir)/src/common/compat/libcompat.la \
                $(UUID_LIBS)
 
-if BUILD_LIB_RUNAS
-libcommon_la_SOURCES += runas.c lttng-elf.h lttng-elf.c
-else
-libcommon_la_SOURCES += runas-stub.c
-endif
-
-if BUILD_LIB_UNIX
-libcommon_la_SOURCES += unix.c
-else
-libcommon_la_SOURCES += unix-stub.c
-endif
-
 if BUILD_LIB_COMPAT
 SUBDIRS += compat
 endif
This page took 0.025715 seconds and 5 git commands to generate.