Session consumed size notification
[lttng-tools.git] / src / common / Makefile.am
index bdba28f19f2fadcc851babfa11ef950a2d3ae518..5392bf4d94a2f79f5f563f842ab64ba0435a5492 100644 (file)
@@ -1,5 +1,3 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
-
 AUTOMAKE_OPTIONS = subdir-objects
 
 SUBDIRS = string-utils
@@ -58,8 +56,6 @@ if BUILD_LIB_CONSUMER
 SUBDIRS += consumer
 endif
 
-AM_CFLAGS = -fno-strict-aliasing
-
 noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
                                 uri.h utils.h lttng-kernel-old.h \
                                 align.h bitfield.h bug.h time.h
@@ -76,19 +72,15 @@ libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
                        unix.c unix.h \
                        filter.c filter.h context.c context.h \
                        action.c notify.c condition.c buffer-usage.c \
+                       session-consumed-size.c \
                        evaluation.c notification.c trigger.c endpoint.c \
                        dynamic-buffer.h dynamic-buffer.c \
                        buffer-view.h buffer-view.c \
                        waiter.h waiter.c
 
 libcommon_la_LIBADD = \
-               $(top_builddir)/src/common/config/libconfig.la
-if LTTNG_BUILD_WITH_LIBUUID
-libcommon_la_LIBADD += -luuid
-endif
-if LTTNG_BUILD_WITH_LIBC_UUID
-libcommon_la_LIBADD += -lc
-endif
+               $(top_builddir)/src/common/config/libconfig.la \
+               $(UUID_LIBS)
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.023997 seconds and 5 git commands to generate.