Fix: libc internal mutex races with run_as
[lttng-tools.git] / src / common / Makefile.am
index 4b623c837db6bd2cd3e82802e9f01927d2205d02..64110e615e03ed5a28d3c038475fd6f57724d32a 100644 (file)
@@ -8,16 +8,19 @@ AM_CFLAGS = -fno-strict-aliasing
 noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
                                 uri.h utils.h lttng-kernel-old.h \
                                 consumer-metadata-cache.h consumer-timer.h \
-                                consumer-testpoint.h
+                                consumer-testpoint.h align.h bitfield.h bug.h
 
 # Common library
 noinst_LTLIBRARIES = libcommon.la
+EXTRA_DIST = mi_lttng.xsd
 
 libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
                        common.h futex.c futex.h uri.c uri.h defaults.c \
                        pipe.c pipe.h readwrite.c readwrite.h \
                        mi-lttng.h mi-lttng.c \
-                       daemonize.c daemonize.h
+                       daemonize.c daemonize.h \
+                       sessiond-comm/unix.c sessiond-comm/unix.h
+
 libcommon_la_LIBADD = \
                -luuid \
                -lrt \
@@ -40,3 +43,17 @@ if HAVE_LIBLTTNG_UST_CTL
 libconsumer_la_LIBADD += \
                $(top_builddir)/src/common/ust-consumer/libust-consumer.la
 endif
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+               cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+               rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.028331 seconds and 5 git commands to generate.