Move compat to common and create an internal lib
[lttng-tools.git] / src / common / Makefile.am
index a8125bc404407c44451297c30ff60f3d370a6775..6b11d50843cf351d56f17b52668c5338e80a3e99 100644 (file)
@@ -24,3 +24,13 @@ if HAVE_LIBLTTNG_UST_CTL
 libconsumer_la_LIBADD += \
                $(top_builddir)/src/common/ust-consumer/libust-consumer.la
 endif
+
+if COMPAT_EPOLL
+COMPAT=compat/compat-epoll.c
+else
+COMPAT=compat/compat-poll.c
+endif
+
+noinst_LTLIBRARIES += libcompat.la
+
+libcompat_la_SOURCES = compat/poll.h $(COMPAT)
This page took 0.023997 seconds and 5 git commands to generate.