Fix: out-of-tree build: missing xsd file for mi test execution
[lttng-tools.git] / src / common / Makefile.am
index 7011d97a64e08f0a3308d1d88f9fff2ebbcc3bf3..97d0ecc9660b66a5b8b244487bef197ac7315efe 100644 (file)
@@ -8,7 +8,7 @@ AM_CFLAGS = -fno-strict-aliasing
 noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
                                 uri.h utils.h lttng-kernel-old.h \
                                 consumer-metadata-cache.h consumer-timer.h \
-                                consumer-testpoint.h
+                                consumer-testpoint.h align.h bitfield.h bug.h
 
 # Common library
 noinst_LTLIBRARIES = libcommon.la
@@ -41,3 +41,17 @@ if HAVE_LIBLTTNG_UST_CTL
 libconsumer_la_LIBADD += \
                $(top_builddir)/src/common/ust-consumer/libust-consumer.la
 endif
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+               cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+               rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.024386 seconds and 5 git commands to generate.