Fix: out-of-tree build: missing xsd file for mi test execution
[lttng-tools.git] / src / common / Makefile.am
index 7817b40ae8cc2f1a364cf5501702299ff7f3e045..97d0ecc9660b66a5b8b244487bef197ac7315efe 100644 (file)
@@ -1,21 +1,28 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
 
 SUBDIRS = compat health hashtable kernel-ctl sessiond-comm relayd \
-                 kernel-consumer ust-consumer testpoint index
+                 kernel-consumer ust-consumer testpoint index config
 
 AM_CFLAGS = -fno-strict-aliasing
 
 noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
                                 uri.h utils.h lttng-kernel-old.h \
-                                consumer-metadata-cache.h consumer-timer.h
+                                consumer-metadata-cache.h consumer-timer.h \
+                                consumer-testpoint.h align.h bitfield.h bug.h
 
 # Common library
 noinst_LTLIBRARIES = libcommon.la
+EXTRA_DIST = mi_lttng.xsd
 
 libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
                        common.h futex.c futex.h uri.c uri.h defaults.c \
-                       pipe.c pipe.h readwrite.c readwrite.h
-libcommon_la_LIBADD = -luuid
+                       pipe.c pipe.h readwrite.c readwrite.h \
+                       mi-lttng.h mi-lttng.c \
+                       daemonize.c daemonize.h
+libcommon_la_LIBADD = \
+               -luuid \
+               -lrt \
+               $(top_builddir)/src/common/config/libconfig.la
 
 # Consumer library
 noinst_LTLIBRARIES += libconsumer.la
@@ -34,3 +41,17 @@ if HAVE_LIBLTTNG_UST_CTL
 libconsumer_la_LIBADD += \
                $(top_builddir)/src/common/ust-consumer/libust-consumer.la
 endif
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+               cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+               rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.024665 seconds and 5 git commands to generate.