error-query: add lttng_action_path to express the location of an action
[lttng-tools.git] / src / common / Makefile.am
index b90b8854c64f6a9cf80f488e9943b7b336d875d1..a38325d5ad91c0194fe7bbcebeb4b818cb774ad0 100644 (file)
@@ -35,8 +35,9 @@ EXTRA_DIST = mi-lttng-4.0.xsd
 
 libcommon_la_SOURCES = \
        actions/action.c \
-       actions/group.c \
+       actions/list.c \
        actions/notify.c \
+       actions/path.c \
        actions/rotate-session.c \
        actions/snapshot-session.c \
        actions/start-session.c \
@@ -46,7 +47,7 @@ libcommon_la_SOURCES = \
        common.h \
        conditions/buffer-usage.c \
        conditions/condition.c \
-       conditions/on-event.c \
+       conditions/event-rule-matches.c \
        conditions/session-consumed-size.c \
        conditions/session-rotation.c \
        context.c context.h \
@@ -58,6 +59,7 @@ libcommon_la_SOURCES = \
        dynamic-buffer.c dynamic-buffer.h \
        endpoint.c \
        error.c error.h \
+       error-query.c \
        evaluation.c \
        event.c \
        event-expr-to-bytecode.c event-expr-to-bytecode.h \
@@ -179,6 +181,11 @@ noinst_HEADERS = \
        uri.h \
        utils.h
 
+noinst_PROGRAMS = filter-grammar-test
+filter_grammar_test_SOURCES = filter-grammar-test.c
+filter_grammar_test_LDADD = \
+       libcommon.la
+
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                for script in $(EXTRA_DIST); do \
This page took 0.024744 seconds and 5 git commands to generate.