error-query: add lttng_action_path to express the location of an action
[lttng-tools.git] / src / common / Makefile.am
index caf588e4093e9017a8138a3883c934bed6bef57c..a38325d5ad91c0194fe7bbcebeb4b818cb774ad0 100644 (file)
@@ -35,17 +35,19 @@ EXTRA_DIST = mi-lttng-4.0.xsd
 
 libcommon_la_SOURCES = \
        actions/action.c \
-       actions/group.c \
+       actions/list.c \
        actions/notify.c \
+       actions/path.c \
        actions/rotate-session.c \
        actions/snapshot-session.c \
        actions/start-session.c \
        actions/stop-session.c \
+       actions/rate-policy.c \
        buffer-view.h buffer-view.c \
        common.h \
        conditions/buffer-usage.c \
        conditions/condition.c \
-       conditions/on-event.c \
+       conditions/event-rule-matches.c \
        conditions/session-consumed-size.c \
        conditions/session-rotation.c \
        context.c context.h \
@@ -57,6 +59,7 @@ libcommon_la_SOURCES = \
        dynamic-buffer.c dynamic-buffer.h \
        endpoint.c \
        error.c error.h \
+       error-query.c \
        evaluation.c \
        event.c \
        event-expr-to-bytecode.c event-expr-to-bytecode.h \
@@ -71,6 +74,7 @@ libcommon_la_SOURCES = \
        fs-handle.c fs-handle.h fs-handle-internal.h \
        futex.c futex.h \
        kernel-probe.c \
+       index-allocator.c index-allocator.h \
        location.c \
        log-level-rule.c \
        mi-lttng.c mi-lttng.h \
@@ -81,6 +85,7 @@ libcommon_la_SOURCES = \
        pipe.c pipe.h \
        readwrite.c readwrite.h \
        runas.c runas.h \
+       shm.c shm.h \
        session-descriptor.c \
        snapshot.c snapshot.h \
        spawn-viewer.c spawn-viewer.h \
@@ -176,6 +181,11 @@ noinst_HEADERS = \
        uri.h \
        utils.h
 
+noinst_PROGRAMS = filter-grammar-test
+filter_grammar_test_SOURCES = filter-grammar-test.c
+filter_grammar_test_LDADD = \
+       libcommon.la
+
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                for script in $(EXTRA_DIST); do \
This page took 0.024375 seconds and 5 git commands to generate.