Fix: Add missing header to makefile
[lttng-tools.git] / src / common / Makefile.am
index ba93810a8c3fe6af5bf8bd7c4188d037de4421ec..b43b37676c181c783cb443624afc345f9d91f3d3 100644 (file)
@@ -1,25 +1,18 @@
-AM_CPPFLAGS =
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
 
-SUBDIRS = hashtable kernel-ctl sessiond-comm kernel-consumer ust-consumer
+SUBDIRS = compat hashtable kernel-ctl sessiond-comm relayd \
+                 kernel-consumer ust-consumer testpoint
 
 AM_CFLAGS = -fno-strict-aliasing
 
-noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h
+noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
+                                uri.h utils.h lttng-kernel-old.h
 
+# Common library
 noinst_LTLIBRARIES = libcommon.la
 
-libcommon_la_SOURCES = runas.c runas.h common.h
-
-if COMPAT_EPOLL
-COMPAT=compat/compat-epoll.c
-else
-COMPAT=compat/compat-poll.c
-endif
-
-noinst_LTLIBRARIES += libcompat.la
-
-libcompat_la_SOURCES = compat/poll.h compat/fcntl.h compat/splice.h compat/endian.h \
-                       compat/socket.h compat/compat-fcntl.c $(COMPAT)
+libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
+                       common.h futex.c futex.h uri.c uri.h
 
 # Consumer library
 noinst_LTLIBRARIES += libconsumer.la
@@ -30,7 +23,8 @@ libconsumer_la_LIBADD = \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/kernel-consumer/libkernel-consumer.la \
                $(top_builddir)/src/common/hashtable/libhashtable.la \
-               $(top_builddir)/src/common/libcompat.la
+               $(top_builddir)/src/common/compat/libcompat.la \
+               $(top_builddir)/src/common/relayd/librelayd.la
 
 if HAVE_LIBLTTNG_UST_CTL
 libconsumer_la_LIBADD += \
This page took 0.023875 seconds and 5 git commands to generate.