Rename libcommon.so to libcommon-gpl.so
[lttng-tools.git] / src / common / Makefile.am
index cca159e564b53ba6b7f74d303d3e30af17fa4013..beeb7b70c22065f51a992dd816c9d2a437cfbef4 100644 (file)
@@ -23,10 +23,10 @@ DIST_SUBDIRS = \
        fd-tracker
 
 # Common library
-noinst_LTLIBRARIES = libcommon.la
+noinst_LTLIBRARIES = libcommon-gpl.la
 EXTRA_DIST = mi-lttng-4.0.xsd
 
-libcommon_la_SOURCES = \
+libcommon_gpl_la_SOURCES = \
        action.c \
        buffer-usage.c \
        buffer-view.h buffer-view.c \
@@ -70,11 +70,11 @@ libcommon_la_SOURCES = \
        fs-handle.h fs-handle-internal.h fs-handle.c
 
 if HAVE_ELF_H
-libcommon_la_SOURCES += \
+libcommon_gpl_la_SOURCES += \
        lttng-elf.c lttng-elf.h
 endif
 
-libcommon_la_LIBADD = \
+libcommon_gpl_la_LIBADD = \
        $(top_builddir)/src/common/config/libconfig.la \
        $(top_builddir)/src/common/compat/libcompat.la \
        $(top_builddir)/src/common/hashtable/libhashtable.la \
This page took 0.024353 seconds and 5 git commands to generate.