Tests: Fix nprocesses applications shutdown
[lttng-tools.git] / src / common / Makefile.am
index 577dffe856d96bed26f53d10c0f09869a33b335d..c3a947aaaf61094bdf98298dfabd8d92db81222a 100644 (file)
@@ -1,17 +1,19 @@
-AM_CPPFLAGS =
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
 
 SUBDIRS = compat hashtable kernel-ctl sessiond-comm relayd \
                  kernel-consumer ust-consumer testpoint
 
 AM_CFLAGS = -fno-strict-aliasing
 
-noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h uri.h utils.h
+noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
+                                uri.h utils.h lttng-kernel-old.h
 
 # Common library
 noinst_LTLIBRARIES = libcommon.la
 
 libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
-                       common.h futex.c futex.h uri.c uri.h
+                       common.h futex.c futex.h uri.c uri.h defaults.c
+libcommon_la_LIBADD = -luuid
 
 # Consumer library
 noinst_LTLIBRARIES += libconsumer.la
This page took 0.026039 seconds and 5 git commands to generate.