Tests: Fix nprocesses applications shutdown
[lttng-tools.git] / src / common / Makefile.am
index 84bed094fd94f16365cb0d5b8d5a96824f25ce86..c3a947aaaf61094bdf98298dfabd8d92db81222a 100644 (file)
@@ -1,15 +1,19 @@
-AM_CPPFLAGS =
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
 
-SUBDIRS = compat hashtable kernel-ctl sessiond-comm relayd kernel-consumer ust-consumer
+SUBDIRS = compat hashtable kernel-ctl sessiond-comm relayd \
+                 kernel-consumer ust-consumer testpoint
 
 AM_CFLAGS = -fno-strict-aliasing
 
-noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h uri.h utils.h
+noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
+                                uri.h utils.h lttng-kernel-old.h
 
 # Common library
 noinst_LTLIBRARIES = libcommon.la
 
-libcommon_la_SOURCES = utils.c utils.h runas.c runas.h common.h futex.c futex.h uri.c uri.h
+libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
+                       common.h futex.c futex.h uri.c uri.h defaults.c
+libcommon_la_LIBADD = -luuid
 
 # Consumer library
 noinst_LTLIBRARIES += libconsumer.la
This page took 0.024907 seconds and 5 git commands to generate.