credentials: implement is_equal
[lttng-tools.git] / src / common / Makefile.am
index 5303f26431f3c9e1db9791d314cafc7ffeafbb10..c855dcd7a7daffb776b267b0df8804fb10d58d54 100644 (file)
@@ -28,7 +28,10 @@ EXTRA_DIST = mi-lttng-4.0.xsd
 
 libcommon_la_SOURCES = \
        actions/action.c \
+       actions/group.c \
        actions/notify.c \
+       actions/rotate-session.c \
+       actions/snapshot-session.c \
        actions/start-session.c \
        actions/stop-session.c \
        buffer-usage.c \
@@ -36,7 +39,7 @@ libcommon_la_SOURCES = \
        common.h \
        condition.c \
        context.c context.h \
-       credentials.h \
+       credentials.c credentials.h \
        daemonize.c daemonize.h \
        defaults.c \
        dynamic-array.c dynamic-array.h \
@@ -46,18 +49,22 @@ libcommon_la_SOURCES = \
        evaluation.c \
        event.c \
        filter.c filter.h \
+       fd-handle.c fd-handle.h \
        fs-handle.c fs-handle.h fs-handle-internal.h \
        futex.c futex.h \
        location.c \
        mi-lttng.c mi-lttng.h \
        notification.c \
        optional.h \
+       payload.c payload.h \
+       payload-view.c payload-view.h \
        pipe.c pipe.h \
        readwrite.c readwrite.h \
        runas.c runas.h \
        session-consumed-size.c \
        session-descriptor.c \
        session-rotation.c \
+       snapshot.c snapshot.h \
        spawn-viewer.c spawn-viewer.h \
        time.c \
        trace-chunk.c trace-chunk.h \
This page took 0.024013 seconds and 5 git commands to generate.