Revert stubbing of unix socket functions
[lttng-tools.git] / src / common / Makefile.am
index 171748f433aacc32cc3f79254e1cb1ea4e1957ec..d754924ddb58f503f445ad8ae37422afa2932e04 100644 (file)
@@ -12,12 +12,12 @@ DIST_SUBDIRS = compat health hashtable kernel-ctl sessiond-comm relayd \
 noinst_LTLIBRARIES = libcommon.la
 EXTRA_DIST = mi-lttng-3.0.xsd
 
-libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.h runas.c \
+libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.h \
                        common.h futex.c futex.h uri.c uri.h defaults.c \
                        pipe.c pipe.h readwrite.c readwrite.h \
                        mi-lttng.h mi-lttng.c \
                        daemonize.c daemonize.h \
-                       unix.h \
+                       unix.c unix.h \
                        filter.c filter.h context.c context.h \
                        action.c notify.c condition.c buffer-usage.c \
                        session-consumed-size.c \
@@ -27,16 +27,16 @@ libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.h runas.c \
                        buffer-view.h buffer-view.c \
                        location.c \
                        waiter.h waiter.c \
-                       userspace-probe.c
+                       userspace-probe.c event.c
 
 libcommon_la_LIBADD = \
                $(top_builddir)/src/common/config/libconfig.la \
                $(UUID_LIBS)
 
-if BUILD_LIB_UNIX
-libcommon_la_SOURCES += unix.c
+if BUILD_LIB_RUNAS
+libcommon_la_SOURCES += runas.c lttng-elf.h lttng-elf.c
 else
-libcommon_la_SOURCES += unix-stub.c
+libcommon_la_SOURCES += runas-stub.c
 endif
 
 if BUILD_LIB_COMPAT
This page took 0.026587 seconds and 5 git commands to generate.