Backport LTTNG_OPTIONAL util
[lttng-tools.git] / src / common / Makefile.am
index 29a35e6adfb422451b20d0ad76459896293b0f87..e3feaa38f5c639d58ed83070d1ad626410963f2f 100644 (file)
@@ -1,11 +1,12 @@
 AUTOMAKE_OPTIONS = subdir-objects
 
-SUBDIRS =
+SUBDIRS = fd-tracker
 
 # Make sure to always distribute all folders
 # since SUBDIRS is decided at configure time.
 DIST_SUBDIRS = compat health hashtable kernel-ctl sessiond-comm relayd \
-         kernel-consumer ust-consumer testpoint index config consumer
+         kernel-consumer ust-consumer testpoint index config consumer \
+         fd-tracker
 
 if BUILD_LIB_COMPAT
 SUBDIRS += compat
@@ -61,7 +62,7 @@ noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
 
 # Common library
 noinst_LTLIBRARIES = libcommon.la
-EXTRA_DIST = mi-lttng-3.0.xsd
+EXTRA_DIST = mi-lttng-4.0.xsd
 
 libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
                        common.h futex.c futex.h uri.c uri.h defaults.c \
@@ -71,7 +72,8 @@ libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
                        dynamic-buffer.h dynamic-buffer.c \
                        buffer-view.h buffer-view.c \
                        unix.c unix.h \
-                       filter.c filter.h context.c context.h
+                       filter.c filter.h context.c context.h \
+                       optional.h
 
 libcommon_la_LIBADD = \
                $(top_builddir)/src/common/config/libconfig.la
This page took 0.024553 seconds and 5 git commands to generate.