fd-tracker: add an fd-tracker util to common
[lttng-tools.git] / src / common / Makefile.am
index 4b1484e8be637c8bee849e0a2cc0bf43d918410d..e6628f8a47cb5452938fbf5f1b050e64d6580571 100644 (file)
@@ -6,7 +6,7 @@ SUBDIRS = string-utils
 # since SUBDIRS is decided at configure time.
 DIST_SUBDIRS = compat health hashtable kernel-ctl sessiond-comm relayd \
          kernel-consumer ust-consumer testpoint index config consumer \
-         string-utils
+         string-utils fd-tracker
 #
 # Common library
 noinst_LTLIBRARIES = libcommon.la
@@ -39,6 +39,7 @@ endif
 libcommon_la_LIBADD = \
                $(top_builddir)/src/common/config/libconfig.la \
                $(top_builddir)/src/common/compat/libcompat.la \
+               $(top_builddir)/src/common/hashtable/libhashtable.la \
                $(UUID_LIBS)
 
 if BUILD_LIB_COMPAT
@@ -62,7 +63,7 @@ SUBDIRS += sessiond-comm
 endif
 
 if BUILD_LIB_RELAYD
-SUBDIRS += relayd
+SUBDIRS += relayd fd-tracker
 endif
 
 if BUILD_LIB_KERNEL_CONSUMER
This page took 0.023738 seconds and 5 git commands to generate.