Extend API and remove lttng_uri from lttng.h
[lttng-tools.git] / src / lib / lttng-ctl / Makefile.am
index bb5561e792cb76dea2d3622a1539c311b61e37dc..e00a880263adba798a93474b387b9f2cbd4f29b8 100644 (file)
@@ -1,5 +1,5 @@
 lib_LTLIBRARIES = liblttng-ctl.la
-bin_PROGRAMS = filter-grammar-test
+noinst_PROGRAMS = filter-grammar-test
 
 BUILT_SOURCES = filter-parser.h
 AM_YFLAGS = -t -d -v
@@ -13,6 +13,7 @@ liblttng_ctl_la_SOURCES = lttng-ctl.c \
        filter-visitor-ir-check-binary-op-nesting.c \
        filter-visitor-generate-bytecode.c \
        align.h \
+       bug.h \
        filter-ast.h \
        filter-bytecode.h \
        filter-ir.h \
@@ -22,4 +23,6 @@ filter_grammar_test_SOURCES = filter-grammar-test.c
 filter_grammar_test_LDADD = liblttng-ctl.la
 
 liblttng_ctl_la_LIBADD = \
-               $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la
+               $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
+               $(top_builddir)/src/common/libcommon.la \
+               $(top_builddir)/src/common/hashtable/libhashtable.la
This page took 0.025814 seconds and 5 git commands to generate.