Fix: Run tests requiring the python bindings only when they are enabled
[lttng-tools.git] / tests / Makefile.am
index 4824e2215f4dbc77b1c6c41c5a09f4097fb6c3bb..5feaca2d3003e6430885a689de44bd69a8b58ba9 100644 (file)
@@ -1,3 +1,12 @@
-SUBDIRS = .
+SUBDIRS = utils regression unit
 
-dist_noinst_SCRIPTS = runall
+if USE_PYTHON
+check-am:
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+       ./run.sh with_bindings_regression
+else
+check-am:
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+endif
This page took 0.025495 seconds and 5 git commands to generate.