Fix: Run tests requiring the python bindings only when they are enabled
[lttng-tools.git] / tests / Makefile.am
index 761586e4c6bf18d81d28c463c1db666973f6ca00..5feaca2d3003e6430885a689de44bd69a8b58ba9 100644 (file)
@@ -1,11 +1,12 @@
-AM_CFLAGS=-I$(top_srcdir)/include -I$(top_srcdir)/libkernelctl \
-                 -I$(top_srcdir)/liblttngctl -g -Wall
-
-noinst_PROGRAMS = test_sessions
-
-SESSIONS=$(top_srcdir)/ltt-sessiond/session.c
-
-test_sessions_SOURCES = test_sessions.c $(SESSIONS)
+SUBDIRS = utils regression unit
 
+if USE_PYTHON
+check-am:
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+       ./run.sh with_bindings_regression
+else
 check-am:
-       ./runall.sh
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+endif
This page took 0.026324 seconds and 5 git commands to generate.