Fix: Run tests requiring the python bindings only when they are enabled
[lttng-tools.git] / tests / Makefile.am
index bc0f0a59afc336ffb905b37c43f90309758d01d2..5feaca2d3003e6430885a689de44bd69a8b58ba9 100644 (file)
@@ -1,13 +1,12 @@
-SUBDIRS = . tools kernel
-
-AM_CFLAGS = -g -Wall
-AM_LDFLAGS = -lurcu -lurcu-cds
-
-EXTRA_DIST = run-report.py test_list.py utils.sh utils.h runall.sh
-
-if HAVE_LIBLTTNG_UST_CTL
-SUBDIRS += ust
-endif # HAVE_LIBLTTNG_UST_CTL
+SUBDIRS = utils regression unit
 
+if USE_PYTHON
+check-am:
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+       ./run.sh with_bindings_regression
+else
 check-am:
-       ./runall.sh
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+endif
This page took 0.025407 seconds and 5 git commands to generate.